Решено: ADAU1467 не записывает в EEPROM через USBi

Александр Ф.

Well-known member
ADAU1467 https://www.chipdip.ru/product/rdc4-0027-v1
Подключаюсь через USBi https://www.chipdip.ru/product/sigmalink-usbi
ранее через неё записывал в ADAU1452 - всё корректно работало.

IMG_6411.jpg Снимок экрана 2020-10-12 в 19.36.09.png Снимок экрана 2020-10-12 в 19.36.21.png Снимок экрана 2020-10-12 в 19.36.35.png Снимок экрана 2020-10-12 в 19.36.35.png Снимок экрана 2020-10-12 в 19.36.59.png Снимок экрана 2020-10-12 в 19.55.08.png

Пробую записать проект, показывает, что стирает EEPROM, данные записывает, вроде бы успешно. При подключении к 0 I2S PCM5102 гудит как положено, но после выключения и включения питания - проекта в ADAU нет, тишина в эфире. Только если снова загрузись из СигмаСтудии.
Пробовал читать память EEPROM, верифицировать - всё fail.

Подскажите куда смотреть, что попробовать, чтобы проходила запись?
 

onefabis

Well-known member
Можете попробовать скорость записи EEPROM уменьшить.
 

MDrom

Member
Сталкивался с подобным, и как удалось выяснить, дело в регистре конфигурации Master I2C. В 1467 Master SPI и I2C выведены на одни и те же ноги (как у 1452), но есть возможность переключить I2C на отдельную пару ног, однако при этом перестает работать SelfBoot, поэтому переключать нужно програмно уже после загрузки, а в SigmaStudio Master Port I2C должен быть всегда установлен на MP2, MP3 выводах.
 

Вложения

Александр Ф.

Well-known member
Пробовал, как показано на скриншоте (у меня так и стояло там зелененькое) - не помогло.

Пробовал, как https://ez.analog.com/audio/f/q-a/19534/eval-adau1467z-selfboot-issues рассказывали, выставлял MP24 MODE и MP25 MODE - не помогло.

Попробовал как вот тут описывал товарищи действия - https://ez.analog.com/dsp/sigmadsp/...l-not-write-to-self-boot-eeprom/363273#363273

Yes, those are the exact settings I'm using (see below). Here's my procedure for programming the EEPROM:

1. Move the SELFBOOT jumper to OFF.

2. Run a link-compile-download.

3. Program the EEPROM (I proved it here with the logic analyzer and I didn't see any activity on the SPI_M lines)

4. Power off the board, unplug the programmer.

5. Move the SELFBOOT jumper to ON.

6. Power on the device.
Замкнул пинцетом JP1, включил, включил USBi, запустил заливку, выключил. Потом уже без замыкания JP1 включил - есть пищание, залилось!

Но как то это дело не удобно.
Какой джампер посоветуете туда подпаять, чтобы пинцетом каждый раз не тыкать?
 

Александр Ф.

Well-known member
После того, как закоротил JP1 и успешно записал, ADAU стал прошиваться без замыкания JP1.
 

igrushkin

Well-known member
Пытаюсь решить ту же проблему и заметил, что у меня на вкладке multipurpose1 перечислены не пины 12-24, а пины 0-11 с припиской mode 1.
что это может значить и где мне настроить пины 12-24?
 

Александр Ф.

Well-known member
А в multipurpose какие пины тогда, если в multipurpose 1 - 0...11 ?
ЛУчше скриншоты приложить, чтобы понятнее было.
 

igrushkin

Well-known member
То же 0-11, но без приписки mode 1
Multipurpose: 0-11 просто
Multipurpose1: 0-11 mode 1
 

Александр Ф.

Well-known member
Можно попробовать:
1 пересоздать проект с 0 в SigmaStudio (достатчоно подключить adau1452)
2 переставить SigmaStudio
 

mikhalych24

Well-known member
Отпишусь здесь, ибо тема та! Начало истории здесь: https://forum.chipdip.ru/index.php?threads/rdc4-0027-adau1467-raspberry-pi-zero.115/
Все попытки записать EEPROM 25AA1024 провалились! В ЧиД заказал новые 2 шт, Впаял первую - безрезультатно. Неделю имел секс с платой: пытался посмотреть сигналы логическим анализатором, что-то увидел, но не увидел четкую картинку, грешу на кривость китайского клона анализатора Saleae Logic. Потом анализатор перестал вообще что-либо ловить! Выяснилось, что упал сигнал CS, идущий с 32 ноги ADAU на 1 ногу eeprom-ки (там еще резистор подтяжки R4 на 10 кОм). Выпаял eeprom-ку, проверил сигнал на 32 ноге ADAU - стоит единица! Запаиваю последнюю новую микросхему 25AA1024 и о чудо! Со второй попытки запись ПРОИСХОДИТ! Но радость была недолгой.. Все последующие попытки записи не проходят! Смотрю CS - а там опять 0 !!!! (дальше нецензурщина..)
Промежуточный вывод: eeprom-ки умирают от записи! И что дальше? Кто виноват? Плохие eeprom-ки, поджаренная ADAU1467, плохое питание (DSPO 24.576 I2S LINK), что-то еще? Бред какой-то..
 

Andr005

Member
После того, как закоротил JP1 и успешно записал, ADAU стал прошиваться без замыкания JP1.
На adau1452 один раз так получилось и все. Больше не хочет писать. Пробовал залить проект с моргающими светодиодами от 1467, так же один раз залилось и все. Походу платы от ЧиД хреноватенькие.
 

kis

Member
Та же история с 1452. Думал только с ней проблемы. Купил вторую плату, то же самое. В boot режиме (алгоритм замыкания JP) пару раз записалось а потом вообще перестала писать.
 

kis

Member
Новости с полей. Поменял EEPROMку, стало писать... Надолго ли не знаю, но по всей видимости бракованные. На двух платах... Может партия... Не правильно все это... Купил готовое устройство и нужно доработать напильником. А если рученьки кривые или человек паяльник в руках ни когда не держал... Не стал покупать у китайцев, думал поддержать Российского производителя и слегка разочаровался.
 

igrushkin

Well-known member
А есть точно такая же китайская плата? :) или похожая?
Вопрос риторический. Поэтому и «жуем кактус»
 

kis

Member
Нет. Не стал покупать у китайцев хотя там вариантов много... Закажу вторую eeprom ку , на второй плате поменяю, погоняю обе, будет видно... хотелось бы все таки запустить диповские... А то как то деньги на ветер...
 

kis

Member
По цене да... По удобству спорно... Но давайте посчитаем... ДВЕ платы + 2 eeprom ки что бы дня начала, понять в чем подвох, + танцы с бубном и работа паяльником... Экономическая выгода в данном случае так же спорная. Да и разница даже в 1 тыс. рублей при таком раскладе по моему не разница. Я покупал готовое изделие а не конструктор, в надежде на работу "из коробки"... Если бы мне хотелось работать паяльником и заниматься анализом работы этой платы, наверное собрал бы ее сам.
 
Верх