RDC4-0027v2 ADAU1467

Дюжбан

Well-known member
Оторвал вчера пятак self-boot, запаялся рядом на резистор, а ничего не работает. Оказалось дорожка еще одна от него. А нет проекта платы и сиди гадай.
 

xpandemis

Member
ADAU1467 отказывается реагировать на команды с компа. USBI показывает, что коннект есть, но при попытке записать скомпилированный проект в память ADAU пишет Failed comm. Такая же реакция на попытку прошить eeprom через DSP.

При попытке создать простейший проект в Sigma Studio — генератор синуса→регулятор уровня→индикатор уровня — индикатор не работает.

Регистры с платы Sigma Studio не считывает. Eeprom считывает (полностью заполнена нулями).

При включении чип заметно нагревается (~60…65°С).

Что проверял:
  • Визуально просмотрел все выходы на предмет замыкания (с помощью микроскопа).
  • На выходах есть MKLOCK.
  • На первой ноге EEPROM присутствует логическая "1".
  • USBI от ЧиД корректно работает с платой ADAU1701.
  • Пробовал менять кабели USB и шлейфы
  • Пробовал менять источники питания
  • Переустанавливал драйверы USBI
  • Переустанавливал Sigma Studio
  • Менял компьютер
 

Дюжбан

Well-known member
Здравствуйте. Попробуйте так: один джампер ближе к краю платы поставить, второй снят. Перемычку self-boot запаять, плату отключить от всего и подать только питание 3.3в 2а. Подключить программатор по i2c 3 проводами (адрес 0x70) и залить проект. На usbi поморгает светодиод и плата должна стартануть из проект. А вообще при покупке на ней моргают светодиоды если все норм.
 

Дюжбан

Well-known member
Какой именно проект заливать? Можно ли где-то найти стартовый проект с моргалкой? Или можно пытаться залить любой?
Любой наверное пойдет для того чтобы посмотреть как и что примерно, у всех же по разному задумано. Посмотреть как в проекте подключается usbi и в живую. Как mclk настроить. Как что подключить к dsp и что должно быть в проекте. По примерам и по ютубу много видео основы основ.
 

xpandemis

Member
К сожалению включение через SelfBoot по инструкции выше не помогло. По-прежнему те же симптомы.

Подключение в проекте к USBI соответствует реальному физическому подключению?
Подключено по I2c, в проекте также указана эта шина. Пробовал также залить hex от проекта в еепром, показывает, что залито, но в реальности ничего не меняется. с епромки считываются нули
 

xpandemis

Member
Оторвал вчера пятак self-boot, запаялся рядом на резистор, а ничего не работает. Оказалось дорожка еще одна от него. А нет проекта платы и сиди гадай.
У меня случилась та же беда: пятак отклеился от платы. Можно выбрасывать, или есть надежда узнать к чему он подключен? Проект платы еще не рассекречен?
 

Дюжбан

Well-known member
У меня случилась та же беда: пятак отклеился от платы. Можно выбрасывать, или есть надежда узнать к чему он подключен? Проект платы еще не рассекречен?
От резистора R10 идет дорожка к пятачку и на процессор
 

Дюжбан

Well-known member
К сожалению включение через SelfBoot по инструкции выше не помогло. По-прежнему те же симптомы.



Подключено по I2c, в проекте также указана эта шина. Пробовал также залить hex от проекта в еепром, показывает, что залито, но в реальности ничего не меняется. с епромки считываются нули
ну судя потому что плата подключенная к питанию моргэээмигает светодиодами, она целая и грузится с eeprom. Я в теме написал как писать ипром. С замыкание перемычки self-boot плата переключается из режима загрузки с ипром на загрузку с программатора. Закоротили self-boot, кратковременно reset и светодиоды перестают мигать и просто чуть светятся. Далее проект можно загрузить или программировать через меню self-boot!
 

xpandemis

Member
ну судя потому что плата подключенная к питанию моргэээмигает светодиодами, она целая и грузится с eeprom.
Не моргает и не грузится, в том и беда. Я не писал о "моргает"
ADAU1467 отказывается реагировать на команды с компа. USBI показывает, что коннект есть, но при попытке записать скомпилированный проект в память ADAU пишет Failed comm. Такая же реакция на попытку прошить eeprom через DSP.

При попытке создать простейший проект в Sigma Studio — генератор синуса→регулятор уровня→индикатор уровня — индикатор не работает.

Регистры с платы Sigma Studio не считывает. Eeprom считывает (полностью заполнена нулями).

При включении чип заметно нагревается (~60…65°С).
 

Дюжбан

Well-known member
А изначально мигали светодиоды? Замените бп.
Изначально мигали. БП менял. Нппряжение не просаживается.
а ну вот. просто Вы ее криво прошили и она не работает. нужно замкнуть self-boot и тогда она будет работать от программатора.
 

xpandemis

Member
а ну вот. просто Вы ее криво прошили и она не работает. нужно замкнуть self-boot и тогда она будет работать от программатора.
я писал выше, что загрузка с замкнутым selfboot не дала никакого результата. Вы не читаете ответы.
 

Дюжбан

Well-known member
Вечерочка Вам. Бакинские вроде цену убавили, а модуль подорожал более чем на 10%. И остальные модули также. С чем связан такой рост цен?
 
Верх