RasPi DSP Machine 1, ChipDip DAC, ADAU1701 - аудио процессор для Raspberry Pi

Vitalii

Well-known member
Учитывая ваши предыдущие сообщения о подключении, можно с большой вероятностью сделать вывод: это ещё один модуль, который вы испортили.
Не понимаю, как можно, имея картинку подключения, маркировку контактов на плате, как вы писали "перепробовать все варианты" из одного.
Я же писал выше. Складывал их бутербродом друг на друга. Подключил последовательно, на плате с микросхемой одиночный вывод это 10 по даташиту, подтягивал к земле и плюс питания. На плате что с буфферными элементами замкнул 2 и 2 вывода, которые не подписаны. Но я предположил что это плюс питания на всю схему идет. И после схемы 2 вывода питания тоже замкнул. На плате что с буфферными элементами не подписаны выходы их там 3 шт. На схеме только 1 выход. Что это за дополнительные выходы не пойму. Вот подскажите пожалуйста, как мне догадаться , что это за выходы и как их подключить ?
 

Евгений

Administrator
Команда форума
Я же писал выше. Складывал их бутербродом друг на друга. Подключил последовательно, на плате с микросхемой одиночный вывод это 10 по даташиту, подтягивал к земле и плюс питания. На плате что с буфферными элементами замкнул 2 и 2 вывода, которые не подписаны. Но я предположил что это плюс питания на всю схему идет. И после схемы 2 вывода питания тоже замкнул. На плате что с буфферными элементами не подписаны выходы их там 3 шт. На схеме только 1 выход. Что это за дополнительные выходы не пойму. Вот подскажите пожалуйста, как мне догадаться , что это за выходы и как их подключить ?
Так о том и речь. Зачем вы это делаете? Вам привели однозначную схему подключения, указали, что Reflex должен быть мастером. Вы придумываете что-то от себя и делаете всё наоборот. Зачем тогда вы спрашиваете, если все равно делаете по-своему?
 

Vitalii

Well-known member
Я же писал выше. Складывал их бутербродом друг на друга. Подключил последовательно, на плате с микросхемой одиночный вывод это 10 по даташиту, подтягивал к земле и плюс питания. На плате что с буфферными элементами замкнул 2 и 2 вывода, которые не подписаны. Но я предположил что это плюс питания на всю схему идет. И после схемы 2 вывода питания тоже замкнул. На плате что с буфферными элементами не подписаны выходы их там 3 шт. На схеме только 1 выход. Что это за дополнительные выходы не пойму. Вот подскажите пожалуйста, как мне догадаться , что это за выходы и как их подключить ?
 

Вложения

Vitalii

Well-known member
Так о том и речь. Зачем вы это делаете? Вам привели однозначную схему подключения, указали, что Reflex должен быть мастером. Вы придумываете что-то от себя и делаете всё наоборот. Зачем тогда вы спрашиваете, если все равно делаете по-своему?
Так схема включения, которую Вы описали, не работает. Вот по этой причине я и пишу.
 

Евгений

Administrator
Команда форума
Так схема включения, которую Вы описали, не работает. Вот по этой причине я и пишу.
Чтобы так утверждать, нужно сначала эту схему собрать и выполнить рекомендации с Reflex. А вы этого так и не сделали.
 

Vitalii

Well-known member
Так схема включения, которую Вы описали, не работает. Вот по этой причине я и пишу.
Все. Заработало. Наконец-то. Выполнил пайку во всех соединениях. Замкнул все перемычки, которые не указаны в схеме и не подписаны на плате. Теперь можно пользоваться.
 

Вложения

Vitalii

Well-known member
Все. Заработало. Наконец-то. Выполнил пайку во всех соединениях. Замкнул все перемычки, которые не указаны в схеме и не подписаны на плате. Теперь можно пользоваться.
Соединил контакты Reflex выход 1 к входу платы с буфферными элементами. Выход только! самый крайний с маленькими отверстиями. Другие выходы не работают. Их в схеме нет. Не известно, что это такое.
 

Vitalii

Well-known member
Соединил контакты Reflex выход 1 к входу платы с буфферными элементами. Выход только! самый крайний с маленькими отверстиями. Другие выходы не работают. Их в схеме нет. Не известно, что это такое.
Вот что еще заметил при сборке проекта с этими модулями.
На плату , где установлена микросхема , нужно перебросить питание 3.3в. Или воспользоваться раздельным питанием 3.3в.
А на плате, где буфферные элементы расположены, достаточно подать питание с одной стороны. При этом перемычки на плате должны быть замкнуты. Или воспользоваться дополнительным питанием с выходной стороны. При этом перемычки должны быть разомкнуты.
Разработчики из Чип и Дип. Подскажите пожалуйста, как об этом можно догадаться?
Целый день потратил на выяснение причин неработающих плат.
 

Vitalii

Well-known member
Вот что еще заметил при сборке проекта с этими модулями.
На плату , где установлена микросхема , нужно перебросить питание 3.3в. Или воспользоваться раздельным питанием 3.3в.
А на плате, где буфферные элементы расположены, достаточно подать питание с одной стороны. При этом перемычки на плате должны быть замкнуты. Или воспользоваться дополнительным питанием с выходной стороны. При этом перемычки должны быть разомкнуты.
Разработчики из Чип и Дип. Подскажите пожалуйста, как об этом можно догадаться?
Целый день потратил на выяснение причин неработающих плат.
 

Вложения

Vitalii

Well-known member
Здравствуйте. Подскажите пожалуйста, такое подключение справедливо для
HiFi-Pi №3, Digital amplifier for Raspberry Pi 2x60W, SSM3582x2 ?
Здравствуйте. Успешно подключил HiFi-Pi3 к REFLEX. схему приложил.
Вот только помучался я с этой прошивкой.
Что я сделал. Подал питание 12в. на HiFi-Pi3, скачал комбо-проект, распаковал его, открыл в чип-студии, подключил юсб к HiFi-Pi3 и пк. Модуль определился в чип-студии, нажал на кнопку микросхема со стрелочкой-загрузка в микросхему. Загрузка прошла успешно. В окошке, где рядом надпись mc, появилось значение 500. Модуль снова определился в чип-студии и подсветился зеленым. Подключил Reflex, по схеме указанной выше. На Reflex установил джампер на контакт 6. И ву-а-ля, все работает. Но! при нажатии на кнопку, где две микросхемы нарисованы в чип-студии, загрузка комбо-проекта. Загрузка тоже происходит. Но значения в окошке mc меняется на 1500 и работа Reflex уже с шипением, а так же перестают работать все кнопки и регуляторы на HiFi-Pi3. Не понятно с чем это связано.
А в целом, я очень доволен HiFi-Pi3.
 

Вложения

Vitalii

Well-known member
Здравствуйте. Успешно подключил HiFi-Pi3 к REFLEX. схему приложил.
Вот только помучался я с этой прошивкой.
Что я сделал. Подал питание 12в. на HiFi-Pi3, скачал комбо-проект, распаковал его, открыл в чип-студии, подключил юсб к HiFi-Pi3 и пк. Модуль определился в чип-студии, нажал на кнопку микросхема со стрелочкой-загрузка в микросхему. Загрузка прошла успешно. В окошке, где рядом надпись mc, появилось значение 500. Модуль снова определился в чип-студии и подсветился зеленым. Подключил Reflex, по схеме указанной выше. На Reflex установил джампер на контакт 6. И ву-а-ля, все работает. Но! при нажатии на кнопку, где две микросхемы нарисованы в чип-студии, загрузка комбо-проекта. Загрузка тоже происходит. Но значения в окошке mc меняется на 1500 и работа Reflex уже с шипением, а так же перестают работать все кнопки и регуляторы на HiFi-Pi3. Не понятно с чем это связано.
А в целом, я очень доволен HiFi-Pi3.
Подскажите пожалуйста, у Вас новости есть на сайте? И как подписаться на новости? У Вас большой проект готовиться. Как узнать о его выходе в свет? И где о нем можно прочитать?
 

Anatoly84

Member
Добрый день. Приобрел данный набор. Отличная штука! Возникла правда одна проблема. При подключении входов на АЦП не работает вход АЦП0. Все что сделал это в стоковом проекте переключил входные сигналы на входы АЦП 0/1. Один канал работает другой нет.
В чем может быть причина?
 

Vitalii

Well-known member
Добрый день. Приобрел данный набор. Отличная штука! Возникла правда одна проблема. При подключении входов на АЦП не работает вход АЦП0. Все что сделал это в стоковом проекте переключил входные сигналы на входы АЦП 0/1. Один канал работает другой нет.
В чем может быть причина?
Вам нужно разобраться с числом выходов. И на каждом выходе в сигме нужно выставить число соответствующего стерео выхода.
Пример: Первый выход это 0-1, на втором 16-17, на третьем 32-33, на четвёртом 40-41. У меня вот так выставлено. Все работает.
 

Vitalii

Well-known member
Вам нужно разобраться с числом выходов. И на каждом выходе в сигме нужно выставить число соответствующего стерео выхода.
Пример: Первый выход это 0-1, на втором 16-17, на третьем 32-33, на четвёртом 40-41. У меня вот так выставлено. Все работает.
Ой, не туда.
 

Anatoly84

Member
Выходы работают. Только что поставил в проекте переключение входов с цифровых I2S 4/5 на аналоговые ADC0/1. С цифровыми работают оба канала с аналоговыми нет канала 0. Или может я вас не понял?
 

Vitalii

Well-known member
Выходы работают. Только что поставил в проекте переключение входов с цифровых I2S 4/5 на аналоговые ADC0/1. С цифровыми работают оба канала с аналоговыми нет канала 0. Или может я вас не понял?
А посмотрите пожалуйста на плате есть крестик нацарапаный ? Прямо над выходом.
 

Vitalii

Well-known member
Какой сигнал подаёте на 0 канал ? Диференциальный или нет?
 
Верх